ORA-29760: instance_number parameter not specified

Tagged: 

This topic contains 2 replies, has 0 voices, and was last updated by  daniesh 10 years, 2 months ago.

  • Author
    Posts
  • #1890

    daniesh
    Participant

    Hi

    I have installed ASM on the cluster. its a 2 node cluter. i have installed pfile locally.

    i am not able to start asm instance using pfile.

    startup pfile=/u01/app/admin/+ASM/pfile/init+ASM.ora

    ORA-29760: instance_number parameter not specified.

    but i have mentioned the above parameter in my pfile.

    you can find below my pfile parameter setting.

    instance_type=asm

    +ASM1.instance_name=+ASM1

    +ASM2.instance_name=+ASM2

    +ASM1.instance_number=1

    +ASM2.instance_number=2

    I dont know where i am going wrong.

    please help me on this.

    Thanks,

  • #2060

    Amit Bansal
    Keymaster

    Daniesh,

    I think you need to have pfile name as “init+ASM1.ora”

    -Amit

  • #2061

    Saurabh Sood
    Member

    Hi,

    Try to put the following parameters in this pfile:

    *.cluster_database=true

    *.cluster_database_instances=2

    *.instance_type=asm

    Regards,

    Saurabh Sood

You must be logged in to reply to this topic.