Oracle 11g R2 – CRS is not starting

Home Forums Real Application Cluster Oracle 11g R2 – CRS is not starting

This topic contains 2 replies, has 0 voices, and was last updated by  Pankaj Sharma 6 years, 1 month ago.

  • Author
    Posts
  • #1981

    Pankaj Sharma
    Participant

    Hi,

    I am getting problem while starting the CRS. Below is the necessary details:

    1) I am using oracle 11g R2 RAC, with 2 node named RAC1 and RAC2

    2) I have 3 diskgroup named DATA, DATA1, DATA2

    3) OCR and voting disks are stored on ASM diskgroup

    On node RAC1, CRS is started and /etc/oracle/ocr.loc is having the below entry:

    ocrconfig_loc=+DATA

    ocrmirrorconfig_loc=+DATA1

    On node RAC2, CRS is stopped and /etc/oracle/ocr.loc is having the below entry:

    ocrconfig_loc=+DATA

    ocrmirrorconfig_loc=+DATA2

    Please note the difference in “ocrmirrorconfig_loc”. The difference was occured because I updated the OCR location on RAC1 when RAC2 was down.

    Now I am trying to repair the OCR on the RAC2 using below command. This command must be run as root user when HA service is started but CRS must be stopped.

    ocrconfig -repair -replace +DAT2 -replacement +DATA1

    but this showing error “PROT-21: Invalid parameter”, because to run this command diskgroup must be mounted. But diskgroup cannot be mounted until the CRS start. SO this is a conflicting situation.

    Please suggest how to overcome from this problem ?

    Please let me know if you required any other details.

  • #2158

    Amit Bansal
    Keymaster

    Pankaj,

    Stop crs and start using following command

    crsctl start crs -excl -nocrs

    Then try ocrconfig restore . It should work

    -Amit

  • #2159

    Pankaj Sharma
    Participant

    Hi Amit,

    I am using 11.2.0.1, so I used “crsctl start crs -excl”, it worked for me perfactly. I shutdown the CRS on all other nodes and from node2, i used the below command:

    ocrconfig -repair -replace +DATA2 -replacement +DATA1

    Now, all ocr.loc have the same entry on all nodes and I started the cluster on all nodes.

    Thanks a lot…

You must be logged in to reply to this topic.