tns issue / sqlnet issue

Home Forums Real Application Cluster tns issue / sqlnet issue

This topic contains 2 replies, has 0 voices, and was last updated by  Amit Bansal 7 years, 1 month ago.

  • Author
    Posts
  • #1931

    Amit Bansal
    Keymaster

    In 11gR2 RAC, the alert log keeps showing the below errors, the ticket has opened to Oracle support for 1 week. No any progress.

    Thanks in advance.


    Fatal NI connect error 12533, connecting to:

    (DESCRIPTION=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=rss-db205-vip.mtnk)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=RSSDB)(INSTANCE_NAME=RSSDB1)(CID=(PROGRAM=oracle)(HOST=rss-db205.mtnk)(USER=oracle))))

    VERSION INFORMATION:

    TNS for Linux: Version 11.2.0.1.0 – Production

    Time: 09-AUG-2010 18:55:19

    Tracing not turned on.

    Tns error struct:

    ns main err code: 12533

    TNS-12533: TNS:illegal ADDRESS parameters

    ns secondary err code: 12560

    nt main err code: 503

    TNS-00503: Illegal ADDRESS parameters

    nt secondary err code: 0

    nt OS err code: 0

  • #2115

    suvv
    Participant

    Hello Mic,

    The TNS-12533 error usually occurs when the protocol specific parameters in

    the ADDRESS section of the designated connect descriptor in the TNSNAMES.ORA

    are incorrect.Verify if the entries are correct with a simple connect string

    SQLPLUS SCOTT/[email protected]

    If there is no issue for tns entries ,The next thing in a RAC configuration i will verify is the LOCAL_LISTENER and REMOTE_LISTENER settings.I have seen issues where this error is reported for incorrect LOCAL_LISTENER and REMOTE_LISTENER settings.

    Thanks

    Suvv

  • #2116

    Amit Bansal
    Keymaster

    Mic,

    Why are there two entries for Description in tns entry

    <br />
    (DESCRIPTION=(DESCRIPTION=<br />
    

    You have mentioned that this entries are mentioned in alert log. Have you checked the client from which it is coming. Also as Suvv sugested try checking local_listener and remote_listener value. Note that if you are using scan (11gr2), remote_listener should be scanname:<port>

    -Amit

You must be logged in to reply to this topic.