AIX
Number of Cpu’s
$/usr/sbin/lsdev -C -c processor -S Available| wc -l
Memory Details
$/usr/sbin/lsattr -E -l sys0 -a realmem
Swap Configured
$/usr/sbin/lsps -a
To find maximum processes allowed and change it to 10000
$lsattr -El sys0 -a maxuproc #chdev -l sys0 -a maxuproc='10000'
Find memory utilization by process on AIX
ps axwv | awk '{t=t+ - ;print - ,,,,}END{print t}' | sort -rn | pg
Script for Monitoring memory just like vmstat
===============================================
copy the contents in file like mem_mon.sh
### Usage mem_mon.sh (interval) (occurences) e.g sh mem_mon.sh 2 10 ### ### This will give top 10 memory consuming processes ##### wt_time= lmt= let a=0 while [[ $a -lt $lmt ]] ; do ps axwv |sort -nrk 7,7|grep -v "COMMAND" \ |awk 'BEGIN {printf ("MemoryinKb \t ProcessId \t PerCPU \t PerMem \t Command \n")}{t=t+ - ;printf("%13d \t %10d \t %6.2f \t %6.2f \t %s \n", - ,,,,)}END{print t}'|head -10 let a+=1 sleep $wt_time done
Recent Comments